summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2016-01-13 13:50:34 +0100
committerFlorent Le Coz <louiz@louiz.org>2016-01-13 14:01:05 +0100
commit1e79705628af79b2cf6f87a67268f8202774bb9b (patch)
treeff03f66956a9e56c95a7f90eb7a868743d46c476 /CMakeLists.txt
parent25475b60ab363299ddbe5e81ded8968b76838b44 (diff)
downloadbiboumi-1e79705628af79b2cf6f87a67268f8202774bb9b.tar.gz
biboumi-1e79705628af79b2cf6f87a67268f8202774bb9b.tar.bz2
biboumi-1e79705628af79b2cf6f87a67268f8202774bb9b.tar.xz
biboumi-1e79705628af79b2cf6f87a67268f8202774bb9b.zip
Build the doc with the default make target
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ff7be6..3683c39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,7 @@ if(RONN_EXECUTABLE)
add_custom_command(OUTPUT ${MAN_PAGE}
COMMAND ${RONN_EXECUTABLE} --roff < ${DOC_PAGE} > ${MAN_PAGE}
DEPENDS ${DOC_PAGE})
- add_custom_target(doc DEPENDS ${MAN_PAGE})
+ add_custom_target(doc ALL DEPENDS ${MAN_PAGE})
endif()
# Look for litesql and enable the database if found
@@ -124,6 +124,7 @@ target_link_libraries(xmpp xmpplib bridge network utils logger)
if(USE_DATABASE)
target_link_libraries(xmpp database)
+ target_link_libraries(irc database)
endif()
#